Апостроф cms версии 2.65.0 дает ошибку при запуске проекта

Я обновляю версию апострофа с 2.62.0 до 2.65.0. Во время обновления я добавил в настройку mongo driver-3, который все еще работает, я получаю сообщение об ошибке:

(node:116248) Warning: a promise was created in a handler at project/node_modules/async/lib/async.js:167:37 but was not returned from it, see xxxx

Спасибо за помощь в продвижении!

1
0
38
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Это всего лишь предупреждение. bluebird считает, что мы могли непреднамеренно завершить цепочку обещаний, но это сделано намеренно и все в порядке. Он был рассмотрен в Apostrophe 2.68.0 в соответствии с инструкциями bluebird по отключению звука там, где это необходимо, поэтому обновите его до последней версии с помощью npm update, и он остановится.

Спасибо, Том! Обновив апостроф, последняя версия решила проблему.

Rahul Mankar 10.01.2019 07:09

Другие вопросы по теме