Добавление ошибки зависимости image_picker во flutter

Когда я пытаюсь добавить зависимость средства выбора изображений во Flutter, я получаю следующую ошибку:

Error on line 22, column 3 of pubspec.yaml: A package may not list itself as a dependency.

image_picker: ^0.4.10

^^^^^^^^^^^^

1
0
770
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Похоже, вы назвали свой пакет / приложение image_picker, и теперь pub не может отличить его от уже опубликованного фактического image_picker, который вам нужен.

Дважды проверьте свойство name в вашем pubspec.yaml и убедитесь, что это нетimage_picker (или любое другое имя существующего пакета pub, если на то пошло).

Но, пожалуйста, опубликуйте свой полный pubspec.yaml или, что еще лучше, минимально полное воспроизведение этой проблемы, если это не так.

Привет, @Dan, спасибо за ответ! Вот мой файл pubspec.yml: pastebin.com/WiGz8JaU

Deepak Rana 10.09.2018 08:58

Привет, спасибо, ты спас мне день. Вы были правы, я назвал свое приложение image_picker, поэтому я получаю сообщение об ошибке

Deepak Rana 10.09.2018 09:01

Другие вопросы по теме