Docker работает с последним образом postgres alpine

Как я могу указать использование любого последнего образа postgres-alpine при создании docker run?

Я не могу жестко запрограммировать конкретное версионное изображение. Я предполагаю, что есть какой-то способ либо изначально указать «последнее соответствие * -alpine», либо какой-то программный способ проверить доступные теги и оттуда отфильтровать.

Если это важно, это выполняется внутри сценария bash. В конечном итоге фрагмент будет выглядеть как

docker run -it POSTGRES-HERE pg_dump [...]
0
0
493
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Есть тег alpine, который дает последнюю версию.

версия postgres в postgres: alpine - это 10.5, последняя на сегодняшний день. 11 находится в стадии бета-тестирования.

Другие вопросы по теме