Flutter не работает?

I have some problems while running flutter in android studio

Это моя ошибка Запуск lib \ main.dart на Moto C Plus в режиме отладки ... Инициализация gradle ... Устранение зависимостей ... Завершено с ошибкой: проверьте настройки проекта Gradle в папке android /. * Ошибка при запуске Gradle: Код выхода 1 из: D: \ FlutterPrograms \ app \ android \ gradlew.bat app: properties: В NDK отсутствует каталог «платформы». Если вы используете NDK, убедитесь, что для ndk.dir задан допустимый каталог NDK. В настоящее время он установлен на E: \ Sdk \ ndk-bundle. Если вы не используете NDK, снимите значение переменной NDK с ANDROID_NDK_HOME или local.properties, чтобы удалить это предупреждение.

Ошибка оценки проекта, включая ошибку в afterEvaluate {}. Выполните с --stacktrace подробности об ошибке afterEvaluate {}.

ОШИБКА: сбой при сборке за исключением.

  • Где: Строка файла сборки 'D: \ FlutterPrograms \ app \ android \ app \ build.gradle': 25

  • Что пошло не так: Возникла проблема при оценке проекта ": приложение".

    Could not resolve all artifacts for configuration 'classpath'. Could not find lint-gradle-api.jar (com.android.tools.lint:lint-gradle-api:26.1.2). Searched in the following locations: https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar

  • Пытаться: Запустите с параметром --stacktrace, чтобы получить трассировку стека. Запустите с параметром --info или --debug, чтобы получить дополнительный вывод журнала. Запустите с --scan, чтобы получить полную информацию.

  • Получите дополнительную помощь на https://help.gradle.org

СБОЙ СТРОИТЕЛЬСТВА через 1 с.

This is my buid.gradle file

    buildscript {
    repositories {
        maven {
            url 'https://dl.google.com/dl/android/maven2'
        }
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}
rootProject.buildDir = '../build'
subprojects {
    project.buildDir = "${rootProject.buildDir}/${project.name}"
}
subprojects {
    project.evaluationDependsOn(':app')
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

This is my gradle error

    def localProperties = new Properties()
def localPropertiesFile = rootProject.file('local.properties')
if (localPropertiesFile.exists()) {
    localPropertiesFile.withReader('UTF-8') { reader ->
        localProperties.load(reader)
    }
}

def flutterRoot = localProperties.getProperty('flutter.sdk')
if (flutterRoot == null) {
    throw new GradleException("Flutter SDK not found. Define location with flutter.sdk in the local.properties file.")
}

def flutterVersionCode = localProperties.getProperty('flutter.versionCode')
if (flutterVersionCode == null) {
    flutterVersionCode = '1'
}

def flutterVersionName = localProperties.getProperty('flutter.versionName')
if (flutterVersionName == null) {
    flutterVersionName = '1.0'
}

apply plugin: 'com.android.application'
apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"

android {
    compileSdkVersion 27

    lintOptions {
        disable 'InvalidPackage'
    }

    defaultConfig {
        // TODO: Specify your own unique Application ID (https://developer.android.com/studio/build/application-id.html).
        applicationId "com.shanmukh.app"
        minSdkVersion 16
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }

    buildTypes {
        release {
            // TODO: Add your own signing config for the release build.
            // Signing with the debug keys for now, so `flutter run --release` works.
            signingConfig signingConfigs.debug
        }
    }
}

flutter {
    source '../..'
}

dependencies {
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
}

Возможный дубликат не удалось найти lint-gradle-api-26.1.2.jar для проекта флаттера

anmol.majhail 26.10.2018 07:34
stackoverflow.com/questions/52945041/…
anmol.majhail 26.10.2018 07:34
0
2
2 004
3

Ответы 3

В последние дни возникло множество подобных проблем, которые можно было решить, добавив репозиторий google() на первую позицию в блоке repositories скриптов сборки. См. Подробное объяснение в следующих ответах:

Основная причина, связанная с отсутствием библиотек в Jcenter, подробно объясняется здесь: https://stackoverflow.com/a/50885939/6899896

см. stackoverflow.com/a/52947028/6899896: вам необходимо изменить .flutter/packages/flutter_tools/gradle/flutter.gradle в дополнение к сценариям сборки вашего проекта (уровни модуля и приложения), чтобы установить репо google() первым и jcenter() последним

M.Ricciuti 26.10.2018 14:00

Мне очень жаль, что беспокою вас снова и снова. Я очень новичок во Flutter, мне не удалось найти папку с именем .flutter, где находятся папка .flutter и папка flutter.gradle

shanmukh 26.10.2018 14:15

Это должен быть каталог, в который вы установили Flutter.

M.Ricciuti 26.10.2018 14:44

Спасибо за ответ. Я попробую.

shanmukh 26.10.2018 14:51

Оно работает. Большое спасибо за ваш ответ. вы - гений. Большое спасибо.

shanmukh 26.10.2018 15:04

Я нашел решение! Перейдите в папку с флаттером. После вам нужно найти flutter.gradle. На моем ПК: C: \ SRC \ флаттер \ пакеты \ flutter_tools \ gradle Откройте flutter.gradle с помощью заметки или блокнота и измените buildscript из этого:

 repositories {
   jcenter()
    maven {
        url 'https://dl.google.com/dl/android/maven2'
    }    
}

к этому:

 repositories {
    maven {
        url 'https://dl.google.com/dl/android/maven2'
    } 
    jcenter()
}

Откройте корневую папку flutter на вашем компьютере и откройте папку gradle в этой корневой папке (например, C: \ flutter \ package \ flutter_tool \ gradle) и добавьте 'Google()' в скрипт сборки. Это устранило проблему для меня.

Корневая папка Flutter:

enter image description here

Добавьте 'Google()' в скрипт сборки:

enter image description here

Другие вопросы по теме