Как использовать конкретную версию nuget dll в решении

Тип AuthenticationResult существует как в Microsoft.AspNetCore.Authentication.Abstraction, Version 2.0.0.0 и Microsoft.AspNetCore.Authentication, Version=1.1.2.0

Я хочу использовать версию 1.1.2.0. Как мне это сделать?

У них определенно разное пространство имен, так что используйте его.

Adrian 10.09.2018 13:20
0
1
193
1

Ответы 1

Если вы используете консоль Nuget Package Manager для установки пакетов (это самый простой способ установки), обратитесь к этому ссылка на stackoverflow, который демонстрирует использование версионных установок пакетов.

Если вы используете параметр «Управление пакетами Nuget для решения» в меню «Инструменты / Диспетчер пакетов Nuget», вы можете выбрать версию в раскрывающемся списке, который отображается в параметрах установки при выборе пакета для установки.

Если вы установили оба пакета (я вижу, что у них нет одного и того же пространства имен), чтобы использовать конкретную версию пакета, вы можете просто импортировать это конкретное пространство имен в класс

Другие вопросы по теме