Конфликт при развертывании Python Django API

Пожалуйста, я новичок в Python и Django, друг (не разработчик) обратился ко мне по поводу развертывания django в digitalocean. Я пытался устранить некоторые из своих проблем, но не понимаю, как решить последнюю:

 The conflict is caused by:
            The user requested Django==2.2.16
            django-cors-headers 3.2.1 depends on Django>=1.11
            django-filter 2.0.0 depends on Django>=1.11
            django-phonenumber-field 4.0.0 depends on Django>=1.11.3
            django-rest-knox 3.0.3 depends on django
            django-rq 2.3.2 depends on django>=2.0
            djangorestframework 3.11.1 depends on django>=1.11
            drf-yasg 1.20.0 depends on Django>=2.2.16
            django-rest-logger 1.0.4 depends on Django<=2.2 and >=1.11
        
        To fix this you could try to:
        1. loosen the range of package versions you've specified
        2. remove package versions to allow pip attempt to solve the dependency conflict
        
        ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
 ERROR: failed to build: exit status 1

Я пытался посетить адрес, но не знаю, что делать с предоставленной информацией. Пожалуйста, помогите мне

Анализ настроения постов в Twitter с помощью Python, Tweepy и Flair
Анализ настроения постов в Twitter с помощью Python, Tweepy и Flair
Анализ настроения текстовых сообщений может быть настолько сложным или простым, насколько вы его сделаете. Как и в любом ML-проекте, вы можете выбрать...
7 лайфхаков для начинающих Python-программистов
7 лайфхаков для начинающих Python-программистов
В этой статье мы расскажем о хитростях и советах по Python, которые должны быть известны разработчику Python.
Установка Apache Cassandra на Mac OS
Установка Apache Cassandra на Mac OS
Это краткое руководство по установке Apache Cassandra.
Сертификатная программа "Кванты Python": Бэктестер ансамблевых методов на основе ООП
Сертификатная программа "Кванты Python": Бэктестер ансамблевых методов на основе ООП
В одном из недавних постов я рассказал о том, как я использую навыки количественных исследований, которые я совершенствую в рамках программы TPQ...
Создание персонального файлового хранилища
Создание персонального файлового хранилища
Вы когда-нибудь хотели поделиться с кем-то файлом, но он содержал конфиденциальную информацию? Многие думают, что электронная почта безопасна, но это...
Создание приборной панели для анализа данных на GCP - часть I
Создание приборной панели для анализа данных на GCP - часть I
Недавно я столкнулся с интересной бизнес-задачей - визуализацией сбоев в цепочке поставок лекарств, которую могут просматривать врачи и...
2
0
21
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Это очень очевидно из сообщения об ошибке, если вы внимательно его прочитаете.

The user requested Django==2.2.16, но django-rest-logger 1.0.4 depends on Django<=2.2 and >=1.11. Как предлагалось в сообщении об ошибке, вам следует либо ослабить версию Django с 2.2.16 до 2.2, либо удалить django-rest-logger

спасибо, позвольте мне попробовать это. я изменил версию Django с 2.2.11 на 2.2.16

Ibrahim Hammed 09.04.2022 18:22

вы должны понизить его до 2.2 (2.2.0)

Yunusov 09.04.2022 18:33

Другие вопросы по теме