Leveldb в рабочем потоке node.js

Я не могу требовать модуль понижения уровня в рабочем потоке node.js:

var levelup = require('levelup')
var leveldown = require('leveldown')

Я получаю такую ​​ошибку:

Buffer 68 65 6c 6c 6f>
Hello from main!

events.js:167
  throw er; // Unhandled 'error' event
  ^
Error: Module did not self-register.

Пожалуйста, помогите, как это понять.

Какую версию узла вы используете?

Luna 10.08.2018 17:22

Узел версии 10.8.0

Vladimir Kovalchuk 11.08.2018 18:18

Похоже, вы используете модуль узла, который скомпилирован для вашей архитектуры. Вы пытались восстановить модули с помощью npm. Попробуйте также перестроить node-gyp;)

Luna 16.08.2018 16:30

Здесь точно такая же проблема и нет решения.

Daniel 28.02.2019 11:53
2
4
145
0

Другие вопросы по теме