Не найден модуль 'corsheaders' django / heroku deploy

Ни один из других ответов не помог мне. Я делал pipenv install django-cors-headers, pipenv install psycopg2-binary и т. д., Пока на моих пальцах не образовались волдыри, но безрезультатно ...

Это будет немного долго, если вы не против посмотреть; заранее спасибо...

*settings.py*

# Application definition

INSTALLED_APPS = [
    'corsheaders',
    'rest_framework',
    'rest_framework.authtoken',
    'quizzes',
    'django.contrib.admin',
    'django.contrib.auth',
    'django.contrib.contenttypes',
    'django.contrib.sessions',
    'django.contrib.messages',
    'django.contrib.staticfiles'
] 


MIDDLEWARE = [
    'corsheaders.middleware.CorsMiddleware',
    'django.middleware.common.CommonMiddleware',
    'django.middleware.security.SecurityMiddleware',
    'whitenoise.middleware.WhiteNoiseMiddleware',
    'django.middleware.security.SecurityMiddleware',
    'django.contrib.sessions.middleware.SessionMiddleware',
    'django.middleware.common.CommonMiddleware',
    'django.middleware.csrf.CsrfViewMiddleware',
    'django.contrib.auth.middleware.AuthenticationMiddleware',
    'django.contrib.messages.middleware.MessageMiddleware',
    'django.middleware.clickjacking.XFrameOptionsMiddleware',
]

Это Pipfile нужного уровня ...

[[source]]
url = "https://pypi.org/simple"
verify_ssl = true
name = "pypi"

[requires]
python_version = "3.6"

[packages]
python-decouple = "*"
"psycopg2" = "*"
django-dotenv = "*"
gunicorn = "*"
whitenoise = "*"
dj-database-url = "*"
djangorestframework = "*"
django = "*"
django-cors-headers = "*"
"psycopg2-binary" = "*"

[dev-packages]

Но я все еще получаю трассировку line 17 из ./manage.py и, в конечном счете, нет модуля с именем «corsheaders» ... Я удалил / переустановил и все такое. У кого-нибудь есть идеи?

  • изменить: я использую Ubuntu 18.04

Вы в конце концов нашли ответ? У меня такая же проблема ...

DSteman 29.04.2021 21:33
1
1
541
1

Ответы 1

У меня была аналогичная проблема - попробуйте установить django-cors-headers с помощью pip3 / pip / pipenv. Это решило проблему для меня.

Предложения, на которые нет четких ответов, следует публиковать как комментарий.

Deiv 07.05.2019 16:12

Другие вопросы по теме