Обновление подмодуля не выполняется с последним обновлением

Поскольку я обновил TortoiseGit до последней версии версия 2.7.0.0, Обновление подмодуля теперь не работает и возвращает следующее.

git.exe submodule update --progress --init --recursive --force --merge --remote -- "src/myproject"

usage: git submodule [--quiet] add [-b <branch>] [-f|--force] [--name <name>] [--reference <repository>] [--] <repository> [<path>]
or: git submodule [--quiet] status [--cached] [--recursive] [--] [<path>...]
or: git submodule [--quiet] init [--] [<path>...]
or: git submodule [--quiet] deinit [-f|--force] [--] <path>...
or: git submodule [--quiet] update [--init] [--remote] [-N|--no-fetch] [-f|--force] [--checkout|--merge|--rebase] [--reference <repository>] [--recursive] [--] [<path>...]
or: git submodule [--quiet] summary [--cached|--files] [--summary-limit <n>] [commit] [--] [<path>...]
or: git submodule [--quiet] foreach [--recursive] <command>
or: git submodule [--quiet] sync [--recursive] [--] [<path>...]


git did not exit cleanly (exit code 1) (827 ms @ 9/13/2018 11:05:54 AM)

Я не использую командную строку, я использую контекстное меню TortoiseGit.

Я всегда могу войти в Git Bash здесь и ввести следующие команды, но я хочу знать, почему выполнение этого из контекстного меню не работает.

git submodule update --init --remote -f --recursive Src
0
0
602
2
Перейти к ответу Данный вопрос помечен как решенный

Ответы 2

В командной строке cli есть разница: в TortoiseGit вы проверили опцию merge, а в Git bash - нет. Это может вызвать несовместимость, если вы установили checkout или rebase в конфигурации Git.

Может это связано с: https://tortoisegit.org/issue/3218

Ответ принят как подходящий

Спасибо MrTux

Перейдя по ссылке, которую вы разместили, я остановился на этом комментарии:

Свен Стрикрот @mrtux · 1 месяц назад Владелец Вы проверили, что TortoiseGit использует «правильную» версию Git? Возможно, у вас установлена ​​другая более старая версия, которая не может обрабатывать значение конфигурации.

Ответ заключался в том, чтобы обновить мою версию GIT, которая была 2.08, до последней версии 2.19. Для этого я просто загрузил исполняемый файл, и он автоматически обновил мой GIT.

Другие вопросы по теме