Ошибка дротика: ошибка: импорт дротика: зеркала с --enable-mirrors = false

Файл .yaml ниже:

dependencies:
  flutter:
    sdk: flutter
  cupertino_icons: ^0.1.2
  fluttertoast: ^2.0.9
  dio: ^1.0.6
  json_serializable: ^2.0.0
dev_dependencies:
  build_runner: ^1.0.0
  json_annotation: ^2.0.0

когда я бегу:

Launching lib/main.dart on Android SDK built for x86 in debug mode...
Initializing gradle...
Resolving dependencies...
Gradle task 'assembleDebug'...
Built build/app/outputs/apk/debug/app-debug.apk.
D/OpenGLRenderer( 5350): HWUI GL Pipeline
I/OpenGLRenderer( 5350): Initialized EGL, version 1.4
D/OpenGLRenderer( 5350): Swap behavior 1
D/        ( 5350): HostConnection::get() New Host Connection established 
0xa12b3ec0, tid 5379
D/EGL_emulation( 5350): eglCreateContext: 0xa127cf60: maj 2 min 0 rcv 2
D/        ( 5350): SurfaceInterface::setAsyncMode: set async mode 1
D/EGL_emulation( 5350): eglMakeCurrent: 0xa127cf60: ver 2 0 (tinfo         
0xa177fe80)
E/flutter ( 5350): [ERROR:flutter/shell/common/shell.cc(188)] Dart Error: 
error: import of dart:mirrors with --enable-mirrors=false
E/flutter ( 5350): [ERROR:flutter/shell/common/engine.cc(176)] Could not 
prepare to run the isolate.
E/flutter ( 5350): [ERROR:flutter/shell/common/engine.cc(123)] Engine not prepare and launch isolate.
E/flutter ( 5350): 
[ERROR:flutter/shell/platform/android/android_shell_holder.cc(167)] Could not launch engine in configuration.

Я знаю, что проблема в том, что "json_serializable", но я не знал, как ее решить. или есть ли способ преобразовать между моделью и json

Вы уверены, что у вас нет других зависимостей в вашем pubspec.yaml?

Günter Zöchbauer 26.10.2018 18:38
1
1
3 698
2

Ответы 2

Я наткнулся на ваш пост во время собственного поиска решений вашей проблемы.

Я предполагаю, что вы хотите использовать json_serializable для создания собственного исходного кода. Если это так, у вас должен быть json_serializable: ^2.0.0 под dev_dependencies.

Объяснение

json_serializable внутренне использует dartlang / source_gen. source_gen, в свою очередь, ссылается на dart:mirrors, который не поддерживается во флаттере (как сказано в эта почта).

Короче говоря, длинная история: - удаляя зависимость от json_serializable из зависимостей "сборки", вы удаляете зависимость от зеркал, которая останавливает ваш flutterBuild.


i know the problem is that 'json_serializable' but i didn't know how to resolve it. or is there any way to transform between model and json

Я не совсем понял эту роль. По крайней мере, для меня этой информации недостаточно, чтобы помочь в создании вашей модели.

Можно попробовать, если вы разместите класс, в котором вы используете json_serializable и сгенерированный частичный класс.

я решил это. я импортирую 'пакет: json_serializable / json_serializable.dart'; удалить все в порядке.

XNJin 29.10.2018 01:37

У меня была аналогичная проблема. Я использовал плагин appengine с MethodChannel, и как только я удалил зависимость appengine, все заработало нормально.

Другие вопросы по теме