Ошибка gradle при попытке добавить зависимость для сканера zxing

Я попытался добавить зависимость «me.dm7.barcodescanner: zxing: 1.9.8» для функциональности сканера штрих-кода. Он заполняет ошибку Gradle, как показано на изображении

щелкнуть

1
0
202
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Это происходит потому, что эта библиотека использует старые версии com.android.support libs.

Попробуйте сделать это:

implementation ("me.dm7.barcodescanner:zxing:1.9.8") {
    exclude group: "com.android.support"
}

Другие вопросы по теме