Ошибка: не удалось найти подходящий дистрибутив для requirement.parse ('rest_framework> = 3.6.3')

Я пытаюсь создать пакет python, и вот мой файл setup.py

setup(
    name='django-sso_consumer',
    version='0.1',
    packages=find_packages(),
    include_package_data=True,
    license='BSD License',  # example license
    description='A simple Django app for sso_consumenr and hooks',
    long_description=README,
    url='https://www.example.com/',
    author='Paksign',
    author_email='shoaib@wukla.com',
    classifiers=[
        'Environment :: Web Environment',
        'Framework :: Django',
        'Framework :: Django :: 1.5',  # replace "X.Y" as appropriate
        'Intended Audience :: Developers',
        'License :: OSI Approved :: BSD License',  # example license
        'Operating System :: OS Independent',
        'Programming Language :: Python',
        'Programming Language :: Python :: 3.5',
        'Programming Language :: Python :: 3.6',
        'Topic :: Internet :: WWW/HTTP',
        'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
    ],
    install_requires=[
        'wukla_utils',
        'rest_framework>=3.6.3',
        'django>=1.11.3'
    ]
)

но после запуска sudo python setup.py develop я не могу его установить, и это дает следующую ошибку:

Reading https://pypi.org/simple/ No local packages or working download links found for rest_framework>=3.6.3 error: Could not find suitable distribution for Requirement.parse('rest_framework>=3.6.3')

0
0
7 365
1

Ответы 1

Попробуй поменять на djangorestframework>=3.6.3.

Другие вопросы по теме