Ошибка npm или webpack: не удается найти модуль webpack / lib / removeanddo

Пытаясь исправить ошибку "Popper" компонента material-ui, в которой говорится, что он не может найти его модуль, я выполнил несколько команд npm:

npm установить react-popper @ next --save

npm установить avj

npm install --save-dev webpack

установка npm и обновление npm

После этого я не смог снова скомпилировать проект; Я попытался удалить node_modules, затем установить npm, а также установил модуль webpack-cli.

Терминалenter image description here

package.json

{
  "name": "auto-club-reviews",
  "description": "Auto Club Reviews Blog",
  "version": "1.0.0",
  "author": "Sofianu Alin",
  "dependencies": {
    "@material-ui/core": "^1.4.3",
    "@material-ui/icons": "^1.1.0",
    "gatsby": "^1.9.277",
    "gatsby-link": "^1.6.46",
    "gatsby-plugin-feed": "^1.3.25",
    "gatsby-plugin-google-analytics": "^1.0.31",
    "gatsby-plugin-offline": "^1.0.18",
    "gatsby-plugin-react-helmet": "^2.0.11",
    "gatsby-plugin-react-next": "^1.0.11",
    "gatsby-plugin-sharp": "^1.6.48",
    "gatsby-plugin-typography": "^1.7.19",
    "gatsby-remark-copy-linked-files": "^1.5.37",
    "gatsby-remark-images": "^1.5.67",
    "gatsby-remark-responsive-iframe": "^1.4.20",
    "gatsby-remark-smartypants": "^1.4.12",
    "gatsby-source-contentful": "^1.3.54",
    "gatsby-source-filesystem": "^1.5.39",
    "gatsby-transformer-remark": "^1.7.44",
    "gatsby-transformer-sharp": "^1.6.27",
    "lodash": "^4.17.10",
    "react": "^16.4.2",
    "react-dom": "^16.4.2",
    "react-helmet": "^5.2.0",
    "react-hover": "^1.3.2",
    "react-popper": "^1.0.2",
    "typeface-roboto": "0.0.54",
    "typography-theme-alton": "^0.15.10",
    "typography-theme-lincoln": "^0.15.11",
    "typography-theme-wordpress-2016": "^0.15.10",
    "webpack-command": "^0.4.1"
  },
  "devDependencies": {
    "eslint": "^5.3.0",
    "eslint-plugin-react": "^7.10.0",
    "gh-pages": "^1.2.0",
    "html-webpack-plugin": "^3.2.0",
    "prettier": "^1.14.2",
    "webpack": "^4.16.5",
    "webpack-cli": "^3.1.0",
    "webpack-dev-middleware": "^3.1.3",
    "webpack-dev-server": "^3.1.5"
  },
  "homepage": "https://github.com/gatsbyjs/gatsby-starter-blog#readme",
  "keywords": [
    "gatsby"
  ],
  "license": "MIT",
  "main": "n/a",
  "repository": {
    "type": "git",
    "url": "git+https://github.com/gatsbyjs/gatsby-starter-blog.git"
  },
  "scripts": {
    "dev": "gatsby develop",
    "lint": "./node_modules/.bin/eslint --ext .js,.jsx --ignore-pattern public .",
    "test": "echo \"Error: no test specified\" && exit 1",
    "format": "prettier --trailing-comma es5 --no-semi --single-quote --write 'src/**/*.js' 'src/**/*.md'",
    "develop": "gatsby develop",
    "build": "gatsby build",
    "deploy": "gatsby build --prefix-paths && gh-pages -d public",
    "fix-semi": "eslint --quiet --ignore-pattern node_modules --ignore-pattern public --parser babel-eslint --no-eslintrc --rule '{\"semi\": [2, \"never\"], \"no-extra-semi\": [2]}' --fix gatsby-node.js"
  }
}

Есть идеи, что с кем-нибудь происходит?

В зависимостях, которые вы перечисляете, упоминаются две основные версии 'webpack', которые могут конфликтовать ... возможно, просмотрите и согласовайте это, а также повторите npm 'install' и повторите попытку ...

Robert Rowntree 10.08.2018 17:39

может быть вы можете попробовать yarn вместо npm

Nahid 10.08.2018 17:41

@RobertRacentree Я видел, как кто-то исправлял что-то подобное, рекомендуя иметь только 1 версию webpack; но что происходит, я вижу только "webpack": "^ 4.16.5", все остальное не то же самое

index.jsx 10.08.2018 18:13

вы используете как 4., так и 3. "webpack": "^ 4.16.5", "webpack-cli": "^ 3.1.0",

Robert Rowntree 10.08.2018 18:28

@RobertRadowree Удалил "webpack-cli": "^ 3.1.0", удалил node_modules, затем установил npm. Проблема не исчезла. В этом верхнем комментарии вопрос сказано: начиная с версии Webpack 4 вам необходимо установить webpack-cli.

index.jsx 10.08.2018 18:55

@ index.html вам не нужно, если у вас есть webpack-commander

PlayMa256 10.08.2018 19:08

@ PlayMa256 Я удалил webpack-cli и установил webpack-commander, так как прочитал, что они являются альтернативой друг другу и не могут сосуществовать. Терминал по-прежнему выдает ту же ошибку, что и на скриншоте выше.

index.jsx 10.08.2018 19:14

Я исправил эту проблему с помощью этот ответ

ComNurz 07.03.2019 17:07
0
8
6 344
0

Другие вопросы по теме