Ошибка: получите https://registry-1.docker.io/v2/: net / http: тайм-аут рукопожатия tls в docker.

Я прошел по этой ссылке: Docker push - net / http: таймаут рукопожатия TLS, но это не решило мою проблему. Я просто запускаю https://github.com/sqshq/PiggyMetrics с помощью команды docker-compose up.

Status: Downloaded newer image for sqshq/piggymetrics-mongodb:latest
Pulling rabbitmq (rabbitmq:3-management)...
ERROR: Get https://registry-1.docker.io/v2/: net/http: TLS handshake timeout
[root@ech-10-1XXX PiggyMetrics]#
[root@ech-10-1XXX PiggyMetrics]# docker-compose up
Pulling rabbitmq (rabbitmq:3-management)...
ERROR: Get https://registry-1.docker.io/v2/library/rabbitmq/manifests/3-management: Get https://auth.docker.io/token?scope=repository%3Alibrary%2Frabbitmq%3Apull&service=registry.docker.io: net/http: TLS handshake timeout

Развернуть и запустить код на

uname -a

Linux ech-10-XXXX 4.1.12-61.1.18.el7uek.x86_64 #2 SMP Fri Nov 4 15:48:30 PDT 2016 x86_64 x86_64 x86_64 GNU/Linux

Похоже на проблему с сетью

Jens 10.09.2018 09:17

ну ладно, может быть ты прав. Попробую через некоторое время

Jeff Cook 10.09.2018 09:25
8
2
15 503
6
Перейти к ответу Данный вопрос помечен как решенный

Ответы 6

В большинстве случаев это происходит, когда у меня медленное интернет-соединение. Пожалуйста, проверьте ваше интернет-соединение и повторите попытку.

Возникла та же проблема при загрузке образа докера размером 600 МБ. Похоже, мой интернет был медленным, и мне пришлось переключиться на быстрый интернет, чтобы решить эту проблему.

Bereket Belete 23.05.2020 22:14

Причина в сетевой политике в моем регионе. Вы можете изменить свой адрес зеркала и попробовать, в моих случаях, я изменил адрес зеркала и работает. Я использую macOS Catalina:

"registry-mirrors" : [
    "https://dockerhub.azk8s.cn"
  ]

Надеюсь, это вам поможет.

enter image description here

Попробуйте переключить ваше интернет-соединение. Если вы подключены через Wi-Fi, попробуйте подключиться к локальной сети.

Ответ принят как подходящий

Я столкнулся с той же ошибкой Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: TLS handshake timeout из-за подключения медленный интернет.

Переход на соединение сравнительно более быстрый интернет сначала не решило мою проблему. Потом я докер перезапущен и все заработало.

$ sudo systemctl restart docker

В Windows 10 перейдите к значку докера в нижнем левом углу окна. Щелкните правой кнопкой мыши на докере, и второй последний вариант - перезапустить докер. ТАДА!

Uday Chauhan 10.12.2020 08:04

Спасибо, сработало у меня как шарм. но блин! зачем нам перезагружать по-настоящему? Я надеюсь, что новая версия Docker исправит это.

mostafa.S 01.06.2021 12:20

У меня была такая же проблема. Это было исправлено сброс настроек демона на Docker Desktop macOS Catalina. Я надеюсь, что это сработает для вас.

Возможные решения

  1. Проверьте скорость интернета и подключитесь к Более быстрый Интернет

  2. Перезапустить докер

  3. Сбросить настройки демона

enter image description here

Если ваш регион ограничен прокси-сервером Docker.

Другие вопросы по теме