Ошибка установки gnuplot - не удалось выполнить рецепт для цели 'qtgnuplot_fr.qm'

При установке gnuplot 5.0.0 (и 5.0.7 тоже) с помощью ./configure && make,

/usr/lib/qt5/bin/lrelease qtterminal/po/qtgnuplot_fr.ts -qm qtgnuplot_fr.qm
/bin/bash: /usr/lib/qt5/bin/lrelease: No such file or directory
Makefile:1335: recipe for target 'qtgnuplot_fr.qm' failed
make[4]: *** [qtgnuplot_fr.qm] Error 127
make[4]: Leaving directory '/home/seolhwa/Downloads/gnuplot-5.0.7/src'
Makefile:1027: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/home/seolhwa/Downloads/gnuplot-5.0.7/src'
Makefile:644: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/home/seolhwa/Downloads/gnuplot-5.0.7/src'
Makefile:419: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/seolhwa/Downloads/gnuplot-5.0.7'
Makefile:357: recipe for target 'all' failed
make: *** [all] Error 2

Сначала я установил gnuplot, используя подходящая установка gnuplot была установлена ​​последняя версия. Но он пропустил pdfcairo. Итак, я установил два необходимых файла dev и другие рекомендуемые файлы dev (для возможного использования терминала qt). Затем я перешел в папку gnuplot и настроил && make. Результат выше. Что я могу сделать, чтобы это исправить?

0
0
175
1

Ответы 1

Поддержка перевода Qt находится в отдельном пакете qttools5 (точное имя зависит от вашего дистрибутива Linux). Если у вас возникнут проблемы с установкой из исходного кода, зачем использовать gnuplot 5.0, а не текущую версию 5.2?

Может быть, неясно в моем сообщении, я не мог использовать pdfcairo с 5.2. Раньше аналогичная ошибка, которая возникала с новейшей версией gnuplot того времени (5.x), устранялась установкой более ранней версии. Поэтому и снизил версию после первого сбоя. Теперь с версией 4.6 pdfcairo работает нормально ...

Liberty 26.10.2018 07:32

Я не вижу в выводе, который вы показываете, что-либо, что связано с pdfcairo. Показанные ошибки вызваны отсутствием программы lrelease, предоставляемой пакетом qttools.

Ethan 26.10.2018 08:40

Понятно. Тем не менее, я не понимаю, почему ошибка только с qt также помешала установке pdfcairo. Также поинтересуйтесь, почему установка gnuplot (не из исходного кода) не загружает автоматически терминалы pdfcairo и qt ..

Liberty 26.10.2018 12:34

Другие вопросы по теме