Ошибка: в django нет модуля с именем util

Мой код выдает ошибку No module named util. Не могли бы вы сказать мне, где я ошибаюсь?

import os
import mongoengine 

DATABASES = 
'default': {
    'ENGINE': 'django_mongodb_engine',
    'NAME'  : 'newdb',
    'USER': 'admin',  
    'PASSWORD': 'admin',  
    'HOST': '127.0.0.1',  
    'PORT': '27017',  
    'SUPPORTS_TRANSACTIONS': False,
  }, 

я получаю следующие ошибки ...

Unhandled exception in thread started by <function wrapper at 
  0x7f7d86a93938>
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/django/utils/autoreload.py", line 227, in wrapper
    fn(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/commands/runserver.py", line 117, in 
  inner_run
    autoreload.raise_last_exception()
  File "/usr/local/lib/python2.7/dist-packages/django/utils/autoreload.py", line 250, in raise_last_exception
    six.reraise(*_exception)
  File "/usr/local/lib/python2.7/dist-packages/django/utils/autoreload.py", line 227, in wrapper
    fn(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/__init__.py", line 27, 
 in setup
    apps.populate(settings.INSTALLED_APPS)
  File "/usr/local/lib/python2.7/dist-packages/django/apps/registry.py", line 108, in populate
    app_config.import_models()
  File "/usr/local/lib/python2.7/dist-packages/django/apps/config.py", line 202, in import_models
    self.models_module = import_module(models_module_name)
  File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/local/lib/python2.7/dist-packages/django/contrib/auth/models.py", line 4, in <module>
    from django.contrib.auth.base_user import AbstractBaseUser, BaseUserManager
  File "/usr/local/lib/python2.7/dist-packages/django/contrib/auth/base_user.py", line 52, in <module>
    class AbstractBaseUser(models.Model):
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/base.py", line 124, in __new__
    new_class.add_to_class('_meta', Options(meta, app_label))
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/base.py", line 330, in add_to_class
    value.contribute_to_class(cls, name)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/options.py", line 214, in contribute_to_class
    self.db_table = truncate_name(self.db_table, connection.ops.max_name_length())
  File "/usr/local/lib/python2.7/dist-packages/django/db/__init__.py", line 33, in __getattr__
    return getattr(connections[DEFAULT_DB_ALIAS], item)
  File "/usr/local/lib/python2.7/dist-packages/django/db/utils.py", line 211, in __getitem__
    backend = load_backend(db['ENGINE'])
  File "/usr/local/lib/python2.7/dist-packages/django/db/utils.py", line 134, in load_backend
    raise ImproperlyConfigured(error_msg)
django.core.exceptions.ImproperlyConfigured: 'django_mongodb_engine' isn't an available database backend.
Try using 'django.db.backends.XXX', where XXX is one of:
    'mysql', 'oracle', 'postgresql', 'sqlite3'
Error was: No module named util

Заранее спасибо.

Пожалуйста, покажите полную трассировку стека

Satevg 26.10.2018 09:02

@Satevg, моя ошибка: попробуйте использовать 'django.db.backends.XXX', где XXX - одно из: 'mysql', 'oracle', 'postgresql', 'sqlite3' Ошибка: нет модуля с именем util

Kabali 26.10.2018 09:05

Я установил драйвер mongoengine для mongodb

Kabali 26.10.2018 09:06

Вы видите это, когда делаете pip freeze | grep mongodb-engine?

Satevg 26.10.2018 09:07

@Satevg., Он вернул django-mongodb-engine == 0.6.0, когда я выполнил pip freeze | grep mongodb-engine

Kabali 26.10.2018 09:09

Проверьте, пожалуйста, эту проблему github.com/django-nonrel/mongodb-engine/issues/167 Предлагается переустановить пакет djangotoolbox

Satevg 26.10.2018 09:14

@Satevg - не устанавливается django-nonrel-1.5-beta

Kabali 26.10.2018 09:28

django-mongodb-engine не выпускался уже несколько лет, поэтому он не работает с поддерживаемой версией Django.

Alasdair 26.10.2018 09:44
0
8
718
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Вы используете старую версию Django, просто обновите версию Django. Проблема устранится автоматически. Отметьте похожий вопрос В Django нет модуля с именем utils

моя версия django - 1.11

Kabali 26.10.2018 09:07

Тогда эта ошибка связана с пакетом mongodb. Проверьте пакет, набрав pip freeze

Anoop Kumar 26.10.2018 09:09

Другие вопросы по теме