Ошибка xcode 10.0 «команда / приложения / xcode 10.app/contents/developer/toolchains/xcodedefault.xctoolchain/usr/bin/swiftc не удалось с кодом выхода 1»

Когда я компилирую свой код в XCode версии 10.0, я получаю эту единственную ошибку, приводящую к сбою компиляции:

Я попробую все возможности, но не могу решить ошибку

  • Очистить Мой проект alt + Shift + Command + K
  • удаление ~ / Library / Developer / Xcode / DerivedData
  • Pod Update

Не могли бы вы проверить, у кого-то из классов такое же имя или нет?

Faysal Ahmed 26.10.2018 07:00

что работает в Xcode 9.2 или 9.4?

Dhaval Umraliya 26.10.2018 07:09

@FaysalAhmed, я проверил весь код, нет такого же класса

Mitesh Ramani 26.10.2018 07:10

@DhavalUmraliya да Он работает правильно в Xcode 9.2 и 9.4

Mitesh Ramani 26.10.2018 07:11

Даже с утра сталкиваюсь с той же проблемой ...

thevikasnayak 28.09.2020 13:42
7
5
4 305
3

Ответы 3

Если вы посмотрите выше ошибки, XCode сообщит вам, какой класс добавлен / объявлен дважды, перейдите к нему и удалите ссылку. Стройте, и все готово.

Предлагается обновить модули до последней версии. Недавно я столкнулся с подобной проблемой. так что я сделал это, и это сработало для меня. моя версия пода была старше.

проверьте это с помощью pod --version, может быть, это вам поможет.

pod deintegrate
pod install
pod update

Я все делаю, перезапускаю Xcode, перестраиваю Project, добавляю toolChains, блокирую разблокировку, но у меня ничего не работает так что есть две возможности сначала, возможно, вы установите бета-версию Xcode

или попробуйте это, эта работа для меня->

Я пытался запустить проект в Xcode12 / Swift4, а проект был написан на Xcode8 / Swift3 поэтому я устанавливаю Xcode версии 11.7 и выполняю эту работу за меня.

если вы не закончили с 11.7, установите другую версию Xcode и попробуйте оцененную версию Может это вам поможет

Другие вопросы по теме