Параллельная обработка в r зависает, когда не на мобильной точке доступа

У меня общая проблема с R-пакетом "parallel", как показано здесь. Команда

cl <- future::makeClusterPSOCK(1, outfile = NULL, verbose = TRUE) 

зависает на машине всякий раз, когда я подключаюсь к Wi-Fi. тем не мение, он отлично работает, когда я захожу на мобильную точку доступа со своего телефона.

Я прочитал все сообщения с просьбами о решениях, но пока лучшей идеей было переустановить мою операционную систему, чего я бы предпочел избежать ...

Любые идеи?

Я использую R версии 3.5.1, Платформа: x86_64-apple-darwin15.6.0 (64-разрядная).

Обновление 1: Когда соединения отключены или я нахожусь в сети Wi-Fi, вывод команды выше выглядит примерно так:

Workers: [n = 1] ‘localhost’
Base port: 11349
Creating node 1 of 1 ...
- setting up node
Starting worker #1 on ‘localhost’: '/Library/Frameworks/R.framework/Resources/bin/Rscript' --default-packages=datasets,utils,grDevices,graphics,stats,methods -e 'parallel:::.slaveRSOCK()' MASTER=localhost PORT=11349 OUT= TIMEOUT=2592000 XDR=TRUE
Waiting for worker #1 on ‘localhost’ to connect back
starting worker pid=4841 on localhost:11349 at 08:37:36.219

На мобильной точке доступа это выглядит очень похоже, но успешно:

Workers: [n = 1] ‘localhost’
Base port: 11501
Creating node 1 of 1 ...
- setting up node
Starting worker #1 on ‘localhost’: '/Library/Frameworks/R.framework/Resources/bin/Rscript' --default-packages=datasets,utils,grDevices,graphics,stats,methods -e 'parallel:::.slaveRSOCK()' MASTER=localhost PORT=11501 OUT= TIMEOUT=2592000 XDR=TRUE
Waiting for worker #1 on ‘localhost’ to connect back
starting worker pid=4892 on localhost:11501 at 08:39:47.070
Connection with worker #1 on ‘localhost’ established
- assigning connection UUID
- collecting session information
Creating node 1 of 1 ... done

Похоже, что брандмауэр блокирует порты, которые R пытается использовать, когда открывает соединение между главным процессом и фоновым рабочим. Что произойдет, если отключить все сети, т.е. перевести ноутбук в режим «самолет»? (PS. Пожалуйста, всегда старайтесь включать и вывод, который вы получаете; там могут быть какие-то подсказки)

HenrikB 26.10.2018 18:39

Спасибо за предложение @HenrikB. Когда я выключаю сеть, команда все еще зависает (см. Правку выше).

C. Pedersen 29.10.2018 08:41

Не уверен, что это имеет значение, но попробовать стоит; вместо (по умолчанию) localhost попробуйте 127.0.0.1, то есть cl <- future::makeClusterPSOCK("127.0.0.1", outfile = NULL, verbose = TRUE). Какая разница?

HenrikB 29.10.2018 21:01

Еще раз спасибо @HenrikB. К сожалению, это приводит к тому же поведению и результату, что и раньше ...

C. Pedersen 31.10.2018 08:48
0
4
74
0

Другие вопросы по теме