Почему я не могу включить завершение вкладки для jsx с помощью emmet в atom ide

Я имею в виду инструкции на https://gist.github.com/ivan-hilckov/a487b21b325441cdbe8c56594a685ec0, но они у меня не работают.

Мой файл package.json:

{
  "name": "atom-ide-setup",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "keywords": [],
  "author": "",
  "license": "ISC",
  "dependencies": {
    "react": "^16.6.0",
    "react-dom": "^16.6.0"
  },
  "devDependencies": {
    "babel-core": "^6.26.3",
    "babel-preset-env": "^1.7.0",
    "babel-preset-react": "^6.24.1"
  }
}

У Atom установлены следующие пакеты сообщества:

emmet
language-babel
language-javascript-jsx (disabled)
atom-ternjs (disabled)
javascript-snippets

Мой файл keymap.cson включает:

'atom-text-editor[data-grammar~="jsx"]:not([mini])':
  'tab': 'emmet:expand-abbreviation-with-tab'

А файл .js, который я редактирую, выглядит так:

import React, { Component } from 'react';

class App extends Component {
  constructor(props) {
    super(props);
  }

  render() {
    return (
      div.myclass  // this doesn't tab expand
    )
  }
}

export default App;

Подозреваю, что что-то упустил или что-то выключено. Но я не знаю что. Любая помощь приветствуется.

1
0
566
2

Ответы 2

Спасибо за комментарии от mikedklein и swelet к другому посту по теме. Начиная с Emmet 2.4.3 command+shift+e работает или добавляет:

'atom-text-editor:not([mini])':'tab':
 'emmet:expand-abbreviation-with-tab'

в файл keymap.cson, который находится в Atom -> Keymap ... в меню. Да, включая одинарные кавычки.

У меня была такая же проблема с использованием emmet с Atom. Что сработало для меня (в Windows), это Ctrl + e

Другие вопросы по теме