После запуска yarn eject в приложении create-response-app выдать новый err_invalid_arg_type ('path', 'string', path);

После запуска yarn eject на create-react-app, когда я пытаюсь запустить yarn start, терминал показывает ошибку примерно так:

$ node scripts/start.js
path.js:39
    throw new ERR_INVALID_ARG_TYPE('path', 'string', path);
    ^

TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. R
eceived type undefined
    at assertPath (path.js:39:11)
    at Object.resolve (path.js:168:7)
    at Object.<anonymous> (C:\projects\aditya-portfolio\config\webpack.config.d
ev.js:193:39)
    at Module._compile (internal/modules/cjs/loader.js:689:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)
    at Module.load (internal/modules/cjs/loader.js:599:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
    at Function.Module._load (internal/modules/cjs/loader.js:530:3)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (C:\projects\aditya-portfolio\scripts\start.js:31:16)
    at Module._compile (internal/modules/cjs/loader.js:689:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:700:10)
    at Module.load (internal/modules/cjs/loader.js:599:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
    at Function.Module._load (internal/modules/cjs/loader.js:530:3)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this com
mand.

Я пытался настроить SCSS в файле конфигурации webpack, но после выполнения конфигурации, когда я пытаюсь запустить yarn start, он всегда терпит неудачу с указанной выше ошибкой. Как я могу это исправить?

как ты добавил scss?

PlayMa256 13.09.2018 20:24

@ PlayMa256 я изменил css на scss в файле wepack.config.dev

aditya kumar 14.09.2018 04:11

модификация, которую вы сделали. Иначе я не могу сказать, что не так.

PlayMa256 14.09.2018 13:33

Вы нашли какое-нибудь решение для этого?

zsubzwary 23.03.2019 02:19

@Zakawat Я снова запустил yarn install , и это устранило мою проблему.

aditya kumar 23.03.2019 08:55

@adityakumar эта проблема была ошибкой в ​​последней версии ReactNative. для получения дополнительной информации и того, как это исправить, посетите: github.com/facebook/react-native/issues/24107

zsubzwary 23.03.2019 12:42

@Zakawat этот вопрос все равно закрыт. хотя я никогда не пробовал это в реакции на родной. Я получил это от reactjs.

aditya kumar 23.03.2019 19:10
1
7
261
0

Другие вопросы по теме