Сборщику не удалось найти совместимые версии для гема "actionpack" - версии не конфликтуют.

Я пытаюсь обновить проект Rails с Rails 4.2.7 до 5.2. Я получаю следующее сообщение от bundle update:

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    haml-rails was resolved to 1.0.0, which depends on
      actionpack (>= 4.0.1)

    rails (= 5.2) was resolved to 5.2.0, which depends on
      actionpack (= 5.2.0)

Мне не кажется, что должен быть конфликт, если я не понимаю требования к версии правильно. Rails требуется пакет действий 5.2.0, haml-rails требуется пакет действий> = 4.0.1. 5.2.0 больше 4.0.1. Где конфликт?

1
0
250
1

Ответы 1

Что ж, я так и не узнал, почему я получаю это сообщение о несовместимых версиях, но я решил свою проблему, закомментировав gem 'haml-rails' в моем Gemfile, запустив bundle update, восстановив gem 'haml-rails' и снова запустив bundle update.

Я до сих пор не знаю, почему так происходит 🤨

Fred Willmore 10.03.2021 00:10

Другие вопросы по теме