Совместимость веб-компонентов a-frame

Я взглянул на спецификацию A-Frame 3D / Virtual Reality:

aframe.io

Несмотря на то, что он выглядит как кивок в сторону веб-компонентов, он, похоже, не соответствует новым стандартам веб-компонентов. Как кто-то уже указывал в Stackoverflow, он использует document.registerElement, который устарел.

Предполагается ли, что A-Frame будет соответствовать стандартам веб-компонентов?

1
0
166
1

Ответы 1

Согласно старым проблемам здесь и здесь в репозитории Github A-Frame:

It's something we'll look at once there's wide support of V1. But switching from polyfill to polyfill will likely introduce bugs due to how closely A-Frame relies and overrides the current one. A-Frame doesn't use vanilla registerElement behavior.

registerElement() устарел, но они используют полифилы, поэтому он будет работать в будущем.

Вам лучше обратиться за обновлением напрямую в A-Frame.

Другие вопросы по теме