Совместимость версии Angular 7 с firebase

Итак, я работаю над этим проектом для своего факультета, где мне нужно создать приложение Angular 7 и загрузить его в облачный провайдер. Для этого я выбрал Firebase.

На данный момент я использую Angular 7.2.0 с узлом 10.9.0, и это нормально. Я использую версию firebase 8.2.0 с firebase-tools 8.20.0 и @angular/fire 5.4.2 (последняя версия @angular/fire, поддерживающая Angular 7). Когда дело доходит до использования firebase (например, я пытался внедрить аутентификацию Google), я получаю ошибки свойств или функций, отсутствующих в пакете firebase, и я почти уверен, что это не синтаксические ошибки, потому что я пробовал несколько способов (просто чтобы убедиться) . И да, firebase настроен правильно, потому что мне удалось получить и распечатать во внешнем интерфейсе некоторые объекты в базе данных.

Я считаю, что проблема заключается в совместимости версий. Являются ли мои версии firebase и firebase-tools слишком высокими? Как я могу узнать, какие версии моих пакетов совместимы с моей версией Angular?

Вот мои зависимости от package.json:

"@angular/core": "~7.2.0",
"@angular/fire": "^5.4.2",
"firebase": "^8.2.0",
"firebase-tools": "^8.20.0",

Заранее большое спасибо, эта проблема остановила мой прогресс на несколько дней.

Формы c голосовым вводом в React с помощью Speechly
Формы c голосовым вводом в React с помощью Speechly
Пытались ли вы когда-нибудь заполнить веб-форму в области электронной коммерции, которая требует много кликов и выбора? Вас попросят заполнить дату,...
Стилизация и валидация html-формы без использования JavaScript (только HTML/CSS)
Стилизация и валидация html-формы без использования JavaScript (только HTML/CSS)
Будучи разработчиком веб-приложений, легко впасть в заблуждение, считая, что приложение без JavaScript не имеет права на жизнь. Нам становится удобно...
Flatpickr: простой модуль календаря для вашего приложения на React
Flatpickr: простой модуль календаря для вашего приложения на React
Если вы ищете пакет для быстрой интеграции календаря с выбором даты в ваше приложения, то библиотека Flatpickr отлично справится с этой задачей....
В чем разница между Promise и Observable?
В чем разница между Promise и Observable?
Разберитесь в этом вопросе, и вы значительно повысите уровень своей компетенции.
Что такое cURL в PHP? Встроенные функции и пример GET запроса
Что такое cURL в PHP? Встроенные функции и пример GET запроса
Клиент для URL-адресов, cURL, позволяет взаимодействовать с множеством различных серверов по множеству различных протоколов с синтаксисом URL.
Четыре эффективных способа центрирования блочных элементов в CSS
Четыре эффективных способа центрирования блочных элементов в CSS
У каждого из нас бывали случаи, когда нам нужно отцентрировать блочный элемент, но мы не знаем, как это сделать. Даже если мы реализуем какой-то...
0
0
21
2
Перейти к ответу Данный вопрос помечен как решенный

Ответы 2

Ответ принят как подходящий

В производственном проекте я использую эти две зависимости, и они отлично работают вместе, для инструментов firebase вы можете проверить совместимость версии страницы npm, но я думаю, что версия 8.20.0 совместима с firebase 8.6.7.

       "@angular/fire": "^6.1.5",
       "firebase": "^8.6.7",

PS: Если вы хотите использовать версию 9.x firebase, конфигурации этой версии и версии 8.x различаются.

Наконец, мне удалось найти хороший выбор версий для моих зависимостей, поэтому:

"@angular/core": "~7.2.0"
"@angular/fire": "^5.4.2"
"firebase": "^7.7.0"
"firebase-tools": "^7.13.1"
and node 10.9.0

Для тех, кто сталкивается с подобной ситуацией, проверьте версии и даты их выпуска на https://npmjs.com/ (мне просто нужно было найти версии firebase и firebase-tools, которые были выпущены до того, как был выпущен мой @angular/fire@5.4.2).

Другие вопросы по теме