В соединении с сервером xinetd отказано

Я использую xinetd в Fedora. Я поместил файл telnet в папку etc / xinetd.d со следующим содержимым:

service telnet
{   
    disable = yes
    id = telnet
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/sbin/in.telnetd
}

Я знаю, что xinetd запущен, потому что, когда я выполняю обслуживание xinetd status, он говорит, что он активен (работает). Когда я делаю netstat -nltp, кажется, что на порту 23 ничего не работает, а telnet localhost возвращает отказ в соединении. Любые идеи?

Stack Overflow - это сайт для вопросов по программированию и разработке. Этот вопрос кажется не по теме, потому что он не о программировании или разработке. См. О каких темах я могу спросить здесь в Справочном центре. Возможно, лучше спросить Суперпользователь или Обмен стеков Unix и Linux.

jww 13.09.2018 21:01
1
1
813
1
Перейти к ответу Данный вопрос помечен как решенный

Ответы 1

Ответ принят как подходящий

Вы добавили это, а затем не сказали xinetd перечитать файлы конфигурации? Вы можете использовать kill -HUP $(< /var/run/xinetd.pid), чтобы перезапустить его с перечитыванием файлов конфигурации при типичной установке.

Кажется, есть недопонимание. Если вы уже редактировали файл конфигурации и xinetd в настоящее время работает, то вы должны сообщить xinetd, чтобы он прочитал новый файл конфигурации. Это то, что делает kill.

Cupcake Protocol 13.09.2018 20:56

Я понимаю, но я никогда не редактировал файл конфигурации, поэтому это может быть проблемой. Может быть, мне нужно что-то отредактировать, чтобы он заработал.

Flama 13.09.2018 23:29

О, может быть, заменить disable = yes на disable = no, а затем перезапустить.

Cupcake Protocol 13.09.2018 23:37

Спасибо, вот и все

Flama 15.09.2018 01:32

Другие вопросы по теме