Всплывающее окно youtube (модальное) в сочетании с mysql / php

У меня проблема. Я хочу сделать видеогалерею с миниатюрой изображения. При нажатии на миниатюру должно появиться всплывающее окно с соответствующим видео на YouTube.

Уникальный идентификатор YouTube, который я сохраняю в базе данных MySQL. Однако, когда я получаю свою галерею и нажимаю на разные миниатюры, она всегда показывает одно и то же видео. Когда я смотрю свой исходный код, отображаются правильные идентификаторы Youtube. Я не могу понять, что не так.

Bootstrap 3 и Youtube в модальном режиме

<?php
            $servername = "localhost";
            $username = "username";
            $password = "password";
            $dbname = "DB";

            // Make connection
            $conn = new mysqli($servername, $username, $password, $dbname);
            // Check connection
            if ($conn->connect_error) {
                die("Connectie mislukt: " . $conn->connect_error);
            } 

            $sql = "SELECT * FROM video ORDER BY id asc LIMIT 0,12";
            $result = $conn->query($sql);
            while($row = $result->fetch_assoc()) {
            //Get YT id from DB.
            $video = "".$row["video"]."";

            if ($result->num_rows > 0) {
                echo "
                <a href=\"#\" class=\"item-gallery-footer wrap-pic-w\" data-toggle=\"modal\" data-target=\"#modal-video-01\"><img src=\"../images/video/".$row["foto"]."\">
                <div class=\"modal fade\" id=\"modal-video-01\" tabindex=\"-1\" role=\"dialog\" aria-hidden=\"true\">
                <div class=\"modal-dialog\" role=\"document\" data-dismiss=\"modal\">
                    <div class=\"close-mo-video-01 trans-0-4\" data-dismiss=\"modal\" aria-label=\"Close\">&times;</div>

                    <div class=\"wrap-video-mo-01\">
                        <div class=\"w-full wrap-pic-w op-0-0\"><img src=\"images/icons/video-16-9.jpg\" alt=\"IMG\"></div>
                        <div class=\"video-mo-01\">
                            <iframe src=\"https://www.youtube.com/embed/$video?rel=0&amp;showinfo=0\" allowfullscreen></iframe>
                        </div>
                    </div>
                </div>
            </div></a>

";  

            }
        }
        ?>

У вас есть те же идентификаторы в ваших модальных окнах, которые недействительны html и, вероятно, также вызывают вашу проблему

Dimitris Filippou 31.10.2018 13:15

К сожалению, это не так. Я использую тот же статический код (для видео). URL-адрес YouTube имеет статический код, а затем он работает.

Vaporub 31.10.2018 17:57
stackoverflow.com/questions/18622508/…
Vaporub 04.11.2018 11:52
0
3
294
0

Другие вопросы по теме